[Neo4j] HA - Unable to read additional data from server sessionid 0x0

Samuel Feng okosioc at gmail.com
Wed Mar 14 16:25:11 CET 2012


Thanks a lot, Peter.

I found another way to bring it up again,

As I thought there should be some incorrect status stored in the graph,
maybe start up the master instance in Non-HA mode can rectify the status. I
tried and that works. Now the HA cluster is running normally.

However, to prevent it happen again, I will setup a 3-node zk cluster.
Thanks a lot~

Thanks and Regards,

Samuel

2012/3/14 Peter Neubauer <peter.neubauer at neotechnology.com>

> Hi there,
> I talked to Chris Gioran and got the following diagnostics:
>
> "This* is
> what happens when in a quorum of 2 ZK instances one goes down.
>
> (*this == the remaining ZK instance - which is not in standalone mode
> - will refuse to accept requests, hence the ZooClient in neo will barf
> and die).
>
> Reproduced it in exactly the same manner: started a 2 ZK quorum and 2
> neo instances using it, brought down one of the zk servers and
> restarted one neo instance - it refused to come online again. If that
> is what you did, then that is what happened."
>
> To bring it up again, I think you need to get a 3 - node ZK cluster up
> and running again before it will accept new cluster nodes again.
>
> Cheers,
>
> /peter neubauer
>
> G:  neubauer.peter
> S:  peter.neubauer
> P:  +46 704 106975
> L:   http://www.linkedin.com/in/neubauer
> T:   @peterneubauer
>
> Neo4j 1.6 released                 - dzone.com/6S4K
> The Neo4j Heroku Challenge   - http://neo4j-challenge.herokuapp.com/
>
>
>
> On Mon, Mar 12, 2012 at 2:00 PM, Samuel Feng <okosioc at gmail.com> wrote:
> > Dear List,
> >
> > I am using neo4j 1.6.1 and embedded HA Mode.
> >
> > The cluster(with 2 servers) works normally at the beginning. However,
> after
> > one server crashed, the cluster can not start up and keep return below
> > logs. Seems both of the two servers are trying to connect each other but
> > failed again again.
> >
> > I tried to remove the version-2 folder to reset the cluster. But the
> > problem exits. Could you please help me how to recover the cluster?
> Thanks
> > a lot
> >
> > =2012-03-12 20:58:45,946 main-SendThread(125.65.108.89:2181) INFO  -
> > [ClientCnxn$SendThread.startConnect] Opening socket connection to server
> > 125.65.108.23/125.65.108.23:2181
> > =2012-03-12 20:58:45,947 main-SendThread(125.65.108.23:2181) INFO  -
> > [ClientCnxn$SendThread.primeConnection] Socket connection established to
> > 125.65.108.23/125.65.108.23:2181, initiating session
> > =2012-03-12 20:58:45,950 main-SendThread(125.65.108.23:2181) INFO  -
> > [ClientCnxn$SendThread.run] Unable to read additional data from server
> > sessionid 0x0, likely server has closed socket, closing socket connection
> > and attempting reconnect
> > =2012-03-12 20:58:46,066 main-SendThread(125.65.108.89:2181) INFO  -
> > [ClientCnxn$SendThread.startConnect] Opening socket connection to server
> > 125.65.108.23/125.65.108.23:2181
> > =2012-03-12 20:58:46,067 main-SendThread(125.65.108.23:2181) INFO  -
> > [ClientCnxn$SendThread.primeConnection] Socket connection established to
> > 125.65.108.23/125.65.108.23:2181, initiating session
> > =2012-03-12 20:58:46,068 main-SendThread(125.65.108.23:2181) INFO  -
> > [ClientCnxn$SendThread.run] Unable to read additional data from server
> > sessionid 0x0, likely server has closed socket, closing socket connection
> > and attempting reconnect
> > =2012-03-12 20:58:46,153 main-SendThread(125.65.108.23:2181) INFO  -
> > [ClientCnxn$SendThread.startConnect] Opening socket connection to server
> > 125.65.108.89/125.65.108.89:2181
> > =2012-03-12 20:58:46,157 main-SendThread(125.65.108.89:2181) INFO  -
> > [ClientCnxn$SendThread.primeConnection] Socket connection established to
> > 125.65.108.89/125.65.108.89:2181, initiating session
> > =2012-03-12 20:58:46,160 main-SendThread(125.65.108.89:2181) INFO  -
> > [ClientCnxn$SendThread.run] Unable to read additional data from server
> > sessionid 0x0, likely server has closed socket, closing socket connection
> > and attempting reconnect
> > =2012-03-12 20:58:46,802 main-SendThread(125.65.108.23:2181) INFO  -
> > [ClientCnxn$SendThread.startConnect] Opening socket connection to server
> > 125.65.108.89/125.65.108.89:2181
> > =2012-03-12 20:58:46,806 main-SendThread(125.65.108.89:2181) INFO  -
> > [ClientCnxn$SendThread.primeConnection] Socket connection established to
> > 125.65.108.89/125.65.108.89:2181, initiating session
> > =2012-03-12 20:58:46,812 main-SendThread(125.65.108.89:2181) INFO  -
> > [ClientCnxn$SendThread.run] Unable to read additional data from server
> > sessionid 0x0, likely server has closed socket, closing socket connection
> > and attempting reconnect
> >
> > Thanks a lot,
> >
> > Samuel
> > _______________________________________________
> > NOTICE: THIS MAILING LIST IS BEING SWITCHED TO GOOGLE GROUPS, please
> register and consider posting at
> https://groups.google.com/forum/#!forum/neo4j
> >
> > Neo4j mailing list
> > User at lists.neo4j.org
> > https://lists.neo4j.org/mailman/listinfo/user
> _______________________________________________
> NOTICE: THIS MAILING LIST IS BEING SWITCHED TO GOOGLE GROUPS, please
> register and consider posting at
> https://groups.google.com/forum/#!forum/neo4j
>
> Neo4j mailing list
> User at lists.neo4j.org
> https://lists.neo4j.org/mailman/listinfo/user
>


More information about the User mailing list