[Neo4j] RRD dependency not having a valid POM

Peter Neubauer peter.neubauer at neotechnology.com
Mon Dec 20 17:30:58 CET 2010


Guys,
I am trying to build the server component site with

mvn site:site

and get a pom validation exception on the rrd dependency:

[INFO] Generating "Dependencies" report.
[WARNING] Deprecated API called - not org.apache.maven.doxia.sink.Sink
instance and no SinkFactory available. Please update this plugin.
[WARNING] POM for 'org.rrd4j:rrd4j:pom:2.0.6:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[ERROR] ProjectBuildingException error :
org.apache.maven.project.InvalidProjectModelException: Failed to
validate POM for project org.rrd4j:rrd4j at Artifact
[org.rrd4j:rrd4j:pom:2.0.6:compile]


Should we try to generate a valid pom, or help the rrd guys to push
their stuff to maven central?

Cheers,

/peter neubauer

GTalk:      neubauer.peter
Skype       peter.neubauer
Phone       +46 704 106975
LinkedIn   http://www.linkedin.com/in/neubauer
Twitter      http://twitter.com/peterneubauer

http://www.neo4j.org               - Your high performance graph database.
http://www.thoughtmade.com - Scandinavia's coolest Bring-a-Thing party.


More information about the User mailing list