[Neo] Online backup fails with suggested Spring transaction integration

Andreas Guenther aguenther at flying-orange.com
Wed May 20 02:00:07 CEST 2009


Johan, Emil,

Oki, I committed a test project resembling a simplification of what I am using in our application.

	https://svn.neo4j.org/laboratory/users/aguenther/testing/transaction

The two relevant test cases I am referring to are:

	#1 ExplicitTransactionBackupTest (succeeds)
	
	#2 SpringBasedTransactionBackupTest (fails)

The second test case relies on Spring's declarative transactions which successfully work otherwise in our application.

I hope the code makes enough sense to spot the underlying problem. Ideally it's just me not properly using Neo ;)

Thanks in advance,
-Andreas

On Tue, May 19, 2009 at 11:34:21PM +0200, Emil Eifrem wrote:
> On Tue, May 19, 2009 at 18:17, Andreas Guenther
> <aguenther at flying-orange.com> wrote:
> > Emil,
> >
> > I'd prefer to upload what I have to the laboratory once my CLA is
> > accepted and a sub folder is available. This will make it easier to keep
> > all my posted issues and testing code in the Neo space for future reference.
> 
> Hi Andreas,
> 
> Good that you brought this up, cause the CLA you sent was actually
> caught by Google's spam filters! :( I'll set it up for you
> immediately.
> 
> Cheers,
> 
> -- 
> Emil Eifrém, CEO [emil at neotechnology.com]
> Neo Technology, www.neotechnology.com
> Cell: +46 733 462 271 | US: 206 403 8808
> http://twitter.com/emileifrem
> _______________________________________________
> Neo mailing list
> User at lists.neo4j.org
> https://lists.neo4j.org/mailman/listinfo/user


More information about the User mailing list