[Neo] Neo4j with Eclipse

Anders Nawroth anders at neotechnology.com
Fri Jul 17 23:32:55 CEST 2009


Hi Vanesa!

> My name is Vanessa and I'm doing a study about Neo4j. I'm using the
> Eclipse editor v3.4 and a Mac Os 10.5 The problem is that I could not
> install Neo4j into eclipse. I tried to install the plugin, I have intalled
> the GEF editor and I tried to install Maven but it didn't work. Is there any
> way to install Neo4j without maven? Could you explain me how? Thank you very
> much. Vanesa.
>   

There should be no need for Maven unless you want to modify the 
Neoclipse plugin (and thus run it from source).

To install Neoclipse you need to install the GEF and Zest plugins first. 
The easiest way should be to use the Ganymede Update Site, see screenshot.

Then install the Neoclipse plugin. If you need to work with neo4j-b8 
databases, go with this version:
http://eclipse.neo4j.org/neoclipse/
otherwise the snapshot version depending on neo4j-b9 is more fun:
http://eclipse.neo4j.org/neoclipse/snapshot/

Please ask again if there' s still a problem with installation. In that 
case, include the Eclipse Configuration Details, found through the About 
dialog, in your message.

/anders

-------------- next part --------------
A non-text attachment was scrubbed...
Name: zest.png
Type: image/png
Size: 71062 bytes
Desc: not available
Url : http://lists.neo4j.org/pipermail/user/attachments/20090717/b4c2affe/attachment-0001.png 


More information about the User mailing list